Jaguar Clubs of North AmericaJCNA Home
- XJS Forum -

I think that my problem is SOLVED

Kevin Ritter
*

forum user since 2012-02-21

 

Gents-

I have placed a couple of different posts on this forum regarding a 1986 XJS than runs for 5 minutes and then dies. After replacing the ECU, cleaning and replacing injectors, new battery, new fuel pump and regulators, I came to the conclusion that the spark progressive became to weak. I was constantly charging the battery with an auto charger and the car would run perfectly well and the battery would show 13.2 volts at idle at the battery and the coil. The car would run well and eventually die. I then recharged the battery and and left the auto charger running. The car was now showing 14.2 volts at idle at the battery and the coil while the car ran and it ran perfectly for twenty minutes before shutting off. I could run the AC blower, windows etc without stalling. I would have suspected the alt but it was showing between 13.2 and 13.4. I think it is the original LUCAS. I will likely dump it for a delco or just buy a really long extension cord and continue to use my charger.




I think that my problem is SOLVED

PETER METRO
Suncoast Jaguar Club *

forum user since 2007-01-31

 

I know exactly what you are going thru!! My XJS 95 has had the same problem for 6 years!! I was told to unplug the trunk lights that did nothing ,Also the seat control was the problem NO NOT true ,new battery did nothing either, someone at Jaguar told me the visor light is the problem,no it is not!! And last one was the alarm system that I had the amps turned down to lowest level and it still whent dead in 3days!!......I have a nice extension cord hocked up in the garage to a charger that I always connect,every day,if I do not in 3 days the car goes dead 6 years later...........Pete



I think that my problem is SOLVED

Doug Dwyer
Jaguar Car Club of Victoria *

forum user since 2007-03-28

 

I wouldn't be surprised if it's the orginal alternator. My experience is that the original Lucas units last a very long time. Good units.

The Lucas you have is rated at 65 amp output as I recall. Adequate but certainly not overly so. Later XJSs were fitted with a Bosch alternator with a 90 amp (or something like that) rating. The Delco swap is popular because it's easy to find 75-80-100-120 amp models for those wanting more output.

Be ready for iffy quality with Delco units. The higher output is nice but they're not neessarily longer lasting than any other.

Cheers
DD

Doug Dwyer
Longview Washington USA
1995 XJR


  LEGAL NOTICES

 

copyright 2002-2008 JAGUAR CLUBS OF NORTH AMERICA, INC.